new member with a few questions

Discussion in 'General Questions' started by acebike, Feb 26, 2016.

  1. acebike

    acebike New Member

    i recently bought a prebuilt huffy nel lusso cruiser with a chinese 80cc engine kit. my question is about the pedals. i let out the clutch and engine starts, and when im accelerating the pedals keep spinning when i let my feet off. if i hold them with my feet on them so they dont spin, i hear a clicking noise in rear end. is this normal? thanks in advance.
     

  2. David Bogle

    David Bogle Member

    Not normal, sounds like a rear hub issue, does this have a coaster brake?
     
  3. acebike

    acebike New Member

    yes huffy factory coaster brake
     
  4. crassius

    crassius Well-Known Member

    check out "sheldonbrown.com" for info about adjusting coaster brake wheels
     
  5. acebike

    acebike New Member

    ok great thank you. would a unproperly adjusted coaster brake cause the pedals to keep spinning?
     
  6. crassius

    crassius Well-Known Member

    yes, there's a spring in there that needs to be held into two locating notches
     
  7. acebike

    acebike New Member

    the spring you are refering to, is it inside the clutch assembly inside the hub?
     
  8. HeadSmess

    HeadSmess Well-Known Member

    yep. you gunna be learning how to dismantle, regrease and re-assemble the good old coaster brake :)

    be glad it isnt a bendix kickback 2 speed coaster unit ;)

    then you gunna be learning about cone spanners and how to adjust the bearing cones...

    though i always sorta left them a bit loose, tightened one axle nut, then sorta managed to get them "just right" as i tightened the other axle nut... a bit of a fiddle, not always reliable or perfect but it worked...
     
  9. acebike

    acebike New Member

    looks like ill have some tinkering to do. should be good practice. thank you everyone
     
Loading...