Engine wont start up

Discussion in 'General Questions' started by Rockjaw, Apr 25, 2014.

  1. Rockjaw

    Rockjaw Member

    Ive got 2 motor bicycles.. one of my bikes just stopped running..I put new plug..new CDI ..I even swaped the carb out...it still wont fire up..maybe the engine is blown..what else would it be? i dont know much about the magneto..could that go out ?

  2. crassius

    crassius Well-Known Member

    first thing to check is whether you have spark
  3. Rockjaw

    Rockjaw Member

    just replaced that plug and the cdi ..so there is spark..
  4. BigBlue

    BigBlue Active Member

    Maybe. It could be your magneto coil. If you ran it in the rain or let it sit out in the rain, it maybe corroded. Corrosion = no spark. Remove the spark plug from the engine. Place the plug into the spark plug boot. Hold the ground electrode to the head of the engine and turn the engine over. It's important that the spark plug stay grounded to the engine head or you may damage the CDI.

    Another possibility is that the kill switch is stuck. Try starting the engine as normal and press on the kill switch several times while pedaling. Sometimes this works. Also, remove the kill switch from the electrical circuit to see if the engine starts.

    Good Luck,

    AKA: BigBlue
  5. Rockjaw

    Rockjaw Member

    ok will try that! thanks! ..
  6. crassius

    crassius Well-Known Member

    if you don't see the spark (or feel it when holding plug in hand) you can't know that you have spark.

    Also, you may have a clogged muffler which can be checked by just loosening the 2 nuts holding it by about a 1/4 inch and see if it starts that way, if so clean or replace the muffler.
  7. Rockjaw

    Rockjaw Member

    ok good advice ;)