Bike having some problems.

Local time
10:55 PM
Joined
Sep 4, 2022
Messages
55
Recently I built a bike and it seems like it should work fine. But it’s having some issues. For starters the bike is a pain to start. Normally you only need to get up to speed a little and let out the clutch. But for me, when I do that my spark doesn’t happen. It only fires when I go pretty quick on the bike. Another issue it’s having is with idling, when it doesn’t start, it kinda goes for a second and makes the bike move faster on its own. Also, when I brake the bike and it comes to a full stop, it just shuts off. I can send a video tomorrow, it’s late where I am right now. Thanks for any help.
 

DAMIEN1307

Moderator
Staff member
Local time
8:55 PM
Joined
Jul 23, 2020
Messages
7,176
Location
Alamogordo, NM, USA
Did you make sure to throw out that Z series junk Chinesium spark plug that came with the motor kit and replace it with a decent NGK-BR6HS???

We just helped someone 2 days ago with the same type of problem as your having...He replaced the plug and was amazed that was all it was that went wrong with it...Just a thought...lol.

 
Local time
10:55 PM
Joined
Sep 4, 2022
Messages
55
Did you make sure to throw out that Z series junk Chinesium spark plug that came with the motor kit and replace it with a decent NGK-BR6HS???

We just helped someone 2 days ago with the same type of problem as your having...He replaced the plug and was amazed that was all it was that went wrong with it...Just a thought...lol.

yep im using an ngk plug
 
Local time
10:55 PM
Joined
Sep 4, 2022
Messages
55
Hi again, sorry for the late response. Double checked and yes they’re definitely tights enough. And I fixed all the leaks I had, still nothing.
 
Local time
10:55 PM
Joined
Sep 4, 2022
Messages
55
Hi again, sorry for the late response. Double checked and yes they’re definitely tights enough. And I fixed all the leaks I had, still nothing.
It’s acts like it’s almost have a hard time spinning over? Like it fires twice stall fires again and stalls and locks the wheels up.
 

noah9988

Well-Known Member
Local time
10:55 PM
Joined
Jul 3, 2021
Messages
442
If you think it's hard to spin over take the spark plug out and roll the bike around a little bit (with the clutch engaged so it moves the piston). It should be smooth and shouldn't drag the tire.
 
Local time
10:55 PM
Joined
Sep 4, 2022
Messages
55
If you think it's hard to spin over take the spark plug out and roll the bike around a little bit (with the clutch engaged so it moves the piston). It should be smooth and shouldn't drag the tire.
Noticed that my spark is really weak at low rpm but kinda picks up once the bike starts to go quick. This might be my problem. The cdi I have I thought that it was really good and gave off solid spark? I have the bbr tuning stage 2 cdi.
 
Top