Giving up!!!

Discussion in 'General Questions' started by Motocruiser, May 26, 2011.

  1. Motocruiser

    Motocruiser Member

    You can check out my post in 2 stroke engines, "upgraded now it won't start". After hours of trouble shooting I'm giving up on this engine. I've got over $2k in this bike and can't afford to keep throwing parts at it. I've got good compression, but can't seem to get spark no matter what I try. I've replaced the CDI, magneto, plug, and nothing works. So frustrated with this build. It's got a 100 miles on it. I honestly thought it would have atleast lasted through the summer.

  2. tone2crazy

    tone2crazy Member

    did you check for spark? if thee is any spark at all, try taking off the carb and start it. if it is flooded it will start and burn of all of the gas.

    how did you spend $2000
  3. machiasmort

    machiasmort Active Member

    Yeah, at least give us a chance! There's some smart people here. Your in the right place.
  4. BikerInFla

    BikerInFla New Member

    Sometimes just as easy to step back for a breather ... easy for me to say:shout: ... but give yourself 30 days and come back a little refreshed .. I do it and works every time.

  5. RedBaronX

    RedBaronX Member

    I don't think that I've spent $2000 myself, but I know I've spent a LOT more than I would have expected for "$200 engine and a bike".

    It's real possible he started with a really nice bike and upgraded with heavy duty wheels and such...
  6. sparky

    sparky Active Member

    $2000 is a good bit, alright. I've bought a pre-built MB shipped to my door, upgrade parts for it, a replacement motor/gearbox, a 29'er with flip-flop hub, a R/S eho35, a Mitsu TLE33, a Nuvinci hub, and -- recently -- FIVE "hornless" seats to test, of which I will likely return 3 or 4 of them. After all that, especially after returning the unwanted seats, I will still be under $2,000.

    As for answering the OP's question. I have a problem with my magneto/CDI. While scouring the web, I saw an electrical engineer's response to a non-sparking engine. The response suggested that the magnets on the flywheel were worn out. Seems reasonable to me that this is your problem, if you've replaced everything else that creates spark...
  7. jaguar

    jaguar Well-Known Member

    Most likely is a bad ground connection at the magneto. Without that then there is no ground path for the ignition coil. On a motorcycle the ignition coil is grounded to the frame, as is the engine. But not so on this engine.
    Grind the contact areas with your dremel or sandpaper. There is shelac that needs to be removed there.
    If still no spark then see if there is AC voltage at the two wires coming from the stator coil. If I remember right it should be around 50 volts at moderate walking speed.
    If it's there then you replaced one crappy chinese cdi/coil with another crappy chinese cdi/coil. From my testing they barely produce enough voltage to spark and so any reduction in performance, for whatever reason, reduces the sytem to a non-functional status. I replaced everything but the stator coil with quality parts a long time ago. I can't believe anyone puts up with this extremely weak link in the system.
  8. srdavo

    srdavo Active Member

  9. Sgt. Howard

    Sgt. Howard Member

    giving up

    check the wire off the top of the coil that is soldered to the coil frame- THAT's where many folks have an issue. **** near gave it up myself this spring untill I revamped that connection. I d/c'd the ground wire off the coil frame, pealed back 1/2" of insulation back of the connector and soldered THAT to the coil wire before I bolted it to the adjacent bolt hole- THAT way, the ground wire is solid to the coil while the frame connection is incidental, not the other way around. Replacing the magneto- the issue I'm describing is common enough that you might have bought the same problem. It does mean that the black wire now goes out with the magneto should you replace it again, but I doubt this will ever be an issue.
    the ld Sgt.
  10. wbuttry

    wbuttry Member

    one question is your white wire hooked to anything or touching any thing at all
  11. Al.Fisherman

    Al.Fisherman Active Member

  12. sparky

    sparky Active Member

    I should start a new thread, but not just yet... :grin5:

    Basically, I could tell that my plug wire was a little rusty, so I decided to replace the whole ignition coil unit (magneto, plug wire, etc.).

    I couldn't get it to fire one time!! I re-adjusted it today to see if it was "too close". No fire. Then I re-adjusted it to be as close as it could be [without rubbing]. No fire.

    I take the plug out, and it *is* getting spark. Try again. No fire.

    I swap out the old ignition coil unit and I get fire almost right away. Hmm....

    It appears to me that both ignition coils are giving off the same amount of spark with the same plug.... so I don't understand why one will fire and the other will not. Makes no sense!!

    Any ideas? :goofy:
  13. retromike3

    retromike3 Member


    I had the problem with my Skyhawk that my CDI sparked but it did spark as hot as it needed to fire. I replaced the one that came with the new kit with the old one I had laying around and it took right off(until the cheep connections rattled loose)

    I later soldered the connections with my old lead based solder and its worked. Just because you have a spark may not be the answer.

  14. buzbikebklyn1

    buzbikebklyn1 New Member

  15. sparky

    sparky Active Member

    I would buy ten of his CDIs if only they fit on my bike!!

    My CDI looks like this...

    I bought two more from a different online dealer, and have been trying to get one to work at different gaps between the CDI's "pickup" and the magneto. NOTHING WORKS!!! I'd return them both, but the dealer is saying that once installed, no returns.... so I have this Catch-22 Dilemma.

    The only real difference that I can see between the "somewhat functional" CDI that I was using and the "new, but non-functional" CDI is that I can just barely see the plug connector spring thingy (because it's got so much rubber that wasn't cut away). On the older, "somewhat functional" CDI, there is no excess rubber, and you can see all kindsa rust/corrosion on that springy connector deally.

    I guess I'll have to cut it off if the guy won't take them both back. :(
  16. retromike3

    retromike3 Member

  17. buzbikebklyn1

    buzbikebklyn1 New Member

    I got the fix for the pick up gap...
    I use a regular everyday business card (or 1 on each side) between the pick up and the rotor and tighten it down, then remove the card (or cards) works every time.
    Last edited: Jun 1, 2011
  18. rustycase

    rustycase New Member

    This is an EZ fix...

    Frustration is the worst enemy of performance.
    Next might be ignorance.

    It is time to grab a six-pack and a fishing pole.
    After a few days, come back and review the advice threads and then proceed with the suitable correction.

    Good luck