*NEW* Front-mount on Schwinn Jaguar

jared3377

Member
Local time
8:10 AM
Joined
Mar 26, 2008
Messages
213
Location
St. Cloud, Minnesota, USA
Here are the pics of my old and new mounts. Previously, I've had many problems with the old mount, which was one bolt through the frame. Now I have a U-bolt type mount which should be MUCH better, thanks to a buddy:

1. My old mount with a hoseclamp-assistant because I'd sheared--AND replaced--at least 4 or 5 bolts.

2. Another pic of the same.

3. Here's a pic (although fuzzy) of the hole in my frame. Notice the concave and cracks that the bolt created (honestly, I'm still worried about the cracks, but I'll keep checking them after each ride...).

4. Here's the newer mount hardware that my MN-buddy Butch sent me. He's a good guy who's helped me a lot.

5. Here's the new mount. I haven't tried it yet, but it feels so solid that I'm very confident.

Any comments are appreciated.......

Happy riding, all!

Jared
 

Attachments

  • 8.14.08.old.mount.w.hoseclamp.jpg
    8.14.08.old.mount.w.hoseclamp.jpg
    93.8 KB · Views: 225
  • 8.14.08.old.onebolt.mount.through.frame.jpg
    8.14.08.old.onebolt.mount.through.frame.jpg
    114 KB · Views: 223
  • 8.14.08.oldmount.holeinframe.w.cracks.jpg
    8.14.08.oldmount.holeinframe.w.cracks.jpg
    44.5 KB · Views: 192
  • 8.14.08.new.mb.mount.hardware.jpg
    8.14.08.new.mb.mount.hardware.jpg
    52.8 KB · Views: 241
  • 8.14.08.new.kickass.mb.mount.jpg
    8.14.08.new.kickass.mb.mount.jpg
    114.1 KB · Views: 239
Top