2 Stroke engine will only stay running if your being pulled down the road pull clutch it dies.

babyblueyes73109

New Member
Local time
8:00 PM
Joined
Nov 25, 2023
Messages
6
Location
Oklahoma City
This is my first motorized bike. The issue is i have replaced the coil pack, spark plug, fuel line and filter, throttle cable, cleaned the carb. The bike motor will run as long as you are peddling it, or being pulled down the road, but as soon as u pull the throttle to give it gas nothing, pull the clutch it dies i'm at a loss on what the "H" is the issue.
Any ideals or advice im open too try anything at this point.
 
This is my first motorized bike. The issue is i have replaced the coil pack, spark plug, fuel line and filter, throttle cable, cleaned the carb. The bike motor will run as long as you are peddling it, or being pulled down the road, but as soon as u pull the throttle to give it gas nothing, pull the clutch it dies i'm at a loss on what the "H" is the issue.
Any ideals or advice im open too try anything at this point.
Try posting a picture of your engine here, so we know what you have going on.
 
The motor isn’t running if you’re pedaling or being pulled down the road. You should check to see your fuel is on and all your electrical connections are correct.
 
Here are the pictures. The bike will start like normal but if it's not moving at 5mhp it dies. Also if I pull the clutch in while it's running it dies. Pulling in the throttle it doesn't seem to do anything.
 

Attachments

  • IMG_20230811_173548133.jpg
    IMG_20230811_173548133.jpg
    208.5 KB · Views: 32
  • IMG_20230812_115854157.jpg
    IMG_20230812_115854157.jpg
    350.6 KB · Views: 33
Try removing the cap from the muffler. See if that helps sort it out. Mine wouldn't run at first with the stock muffler in place.
 
You have an older NT carb, if you look at this thread you can learn how to tune it. Pay close attention to the float height. And yes, it does look like the choke is on, down for "off" and up for "on".

 
Back
Top