GT90 help please

Joined
Feb 1, 2018
Messages
11
Likes
0
#1
Excuse me
I built ones of these GT90 conversion motors. Got it done, but it won't start?
Its getting spark, good plug, lighting bolt CDI.
Can I ask you, when you put the throttle cable on,
Did it fit!
Mine seem to be too short?
It held the carb. About half way on, it seemed?
I made it where the sliding part, goes all the way down?
But now I'm thinking mabe I was wrong?
Mabe needs more air going through?
By raising the sliding part.
 


Spare_Parts

Active Member
Joined
Nov 29, 2017
Messages
665
Likes
225
#2
The slide should be all the way down. How is your compression? Have you checked it? Is your magnet on correctly?
 
Joined
Feb 1, 2018
Messages
11
Likes
0
#3
The slide should be all the way down. How is your compression? Have you checked it? Is your magnet on correctly?
How do I check compression? It feels like there is, when trying to push with clutch engaged,.
I got the magnet at one o'clock to dead center.
If I pure gas in the head or carb., it starts!
So it should be simple, lest I hope. Lol
I love these bikes, until you don't know what to do?
Thank you so much
I need to get this thing going.
 
Joined
Dec 13, 2015
Messages
657
Likes
23
#5
Excuse me
I built ones of these GT90 conversion motors. Got it done, but it won't start?
Its getting spark, good plug, lighting bolt CDI.
Can I ask you, when you put the throttle cable on,
Did it fit!
Mine seem to be too short?
It held the carb. About half way on, it seemed?
I made it where the sliding part, goes all the way down?
But now I'm thinking mabe I was wrong?
Mabe needs more air going through?
By raising the sliding part.
I had one at least I got about 2600 miles out of it then it slowly died on me after a 300 mile trip fortunate that limp back to my town then died completely tried everything to resurrect it from the grave: 3 new plugs, 3 new CDIs, 3 new magnetos, 1 new head, and 1 new jug finally I sh*t trash it bought a new motor and took right off. GT90 I believe you bought from Gazbikes.net try and return it get return shipping number because postage will be nearly $90.00 oh and you are going to be bitter they will not answer the phone or reply to emails knowing you want your money back!
 
Joined
Dec 13, 2015
Messages
657
Likes
23
#8
Excuse me
I built ones of these GT90 conversion motors. Got it done, but it won't start?
Its getting spark, good plug, lighting bolt CDI.
Can I ask you, when you put the throttle cable on,
Did it fit!
Mine seem to be too short?
It held the carb. About half way on, it seemed?
I made it where the sliding part, goes all the way down?
But now I'm thinking mabe I was wrong?
Mabe needs more air going through?
By raising the sliding part.
I had one at least I got about 2600 miles out of it then it slowly died on me after a 300 mile trip fortunate that limp back to my town then died completely tried everything to resurrect it from the grave: 3 new plugs, 3 new CDIs, 3 new magnetos, 1 new head, and 1 new jug finally I sh*t trash it bought a new motor and took right off. GT90 I believe you bought from Gazbikes.net try and return it get return shipping number because postage will be nearly $90.00 oh and you are going to be bitter they will not answer the phone or reply to emails knowing you want your money back!
Did you put case seals in it? It don't come with them and won't run without em.
Can you show me a pic of what a case seal is and where does it go?
 
Joined
Dec 13, 2015
Messages
657
Likes
23
#9
Excuse me
I built ones of these GT90 conversion motors. Got it done, but it won't start?
Its getting spark, good plug, lighting bolt CDI.
Can I ask you, when you put the throttle cable on,
Did it fit!
Mine seem to be too short?
It held the carb. About half way on, it seemed?
I made it where the sliding part, goes all the way down?
But now I'm thinking mabe I was wrong?
Mabe needs more air going through?
By raising the sliding part.
If it motor came with the carb its a real good one has 4" choke lever on the left side has about 4" inch return spring that pulls a stiff cable through the housing and you don't half to choke everytime you kill motor let sit for 5 minutes.

Yes, I would make sure you have enough cable that it does go all the way down. Take a look at the top cap did you mis thread it or is it on crooked its easy to do.
Try taking off filter trying to start or take your reed out see if that is blocking gaz & air. Good luck .
 
Joined
Feb 1, 2018
Messages
11
Likes
0
#11
round, black piece of rubber-like stuff with hole in middle

one on each side of crank shaft outside the case behind rotor & behind small bevel gear
Yes I got new ones with the clutch kit. I'm going to get new gas, it's couple months old . Then check intake for air leaks. I mean it fit start when poured gasoline into it, so can't be to hard to figure out. Gas maybe 3 months old, I don't think it's bad but idk
 
Joined
Feb 1, 2018
Messages
11
Likes
0
#13
Thank you all for replying.
I can see I have a intake leak, on top of reed vale.
I'm hoping that's all it is.
Still getting new gas.
Glad to hear that someone got one of these motors Running
I was worried it may be design flaw
 
Joined
Dec 13, 2015
Messages
657
Likes
23
#14
Thank you all for replying.
I can see I have a intake leak, on top of reed vale.
I'm hoping that's all it is.
Still getting new gas.
Glad to hear that someone got one of these motors Running
I was worried it may be design flaw
I took my reed right off also took the air filter off get oily every time I mix a gallon had to take the filter off wash it in gas. Now the bike has more uniform performance use to one day zoom over the hill at 25mph next day half to pedal it or push it.
 
Joined
Dec 13, 2015
Messages
657
Likes
23
#15
Excuse me
I built ones of these GT90 conversion motors. Got it done, but it won't start?
Its getting spark, good plug, lighting bolt CDI.
Can I ask you, when you put the throttle cable on,
Did it fit!
Mine seem to be too short?
It held the carb. About half way on, it seemed?
I made it where the sliding part, goes all the way down?
But now I'm thinking mabe I was wrong?
Mabe needs more air going through?
By raising the sliding part.
I think I know what it is its the black radiator hose connection take it off put crazy glue around the metal neck next shove it back on all the way up its ass then screw the f*** out of the wedding bands.Should fire up just fine.
 

Top