Sputtering and Backfiring

Zak

Active Member
Joined
Mar 21, 2019
Messages
252
Just quick, I'll check when I get home from work tonight. My bike runs fine but when I get to a stop sign then go, it sputters and backfires and it might clear up or it might not. If it doesnt, I let it sit a couple minutes and it fires back up no problem and goes fine.

Does this sound like a fuel delivery issue to you guys? I changed the filter yesterday and it didn't help, I'm gonna check that screen thing on the petcock tonight.

I've also seen guys mention cleaning the exhaust... I have a stock exhaust and almost 3000 miles I'd say. Ive never touched the exhaust.
 


Purple Haze

Active Member
Joined
Aug 21, 2011
Messages
402
The jet gets clogged in the carb, wouldn't hurt to take the float bowl off and give it a shot of carb cleaner and maybe stick a small diameter wire into the jet hole to make sure it's not blocked.
 

Tyler6357

Active Member
Joined
Sep 28, 2011
Messages
757
Yeah, I would start off cleaning the carb with carb cleaner, it's probably not the exhaust pipe but if you are using a thick oil mix then oil can sometimes clog up stock pipes so air won't flow properly.
 

Zak

Active Member
Joined
Mar 21, 2019
Messages
252
Thanks guys. I haven't done anything to the bike since the last post. I'm parking it for the winter. I'll be asking what I need to rebuild pretty soon probably.

Thank you all so much for your help. It is much appreciated.
 

gary55

Well-Known Member
Joined
Nov 27, 2012
Messages
3,947
Sounds more electrical than fuel. Could also be warped/loose head that starts leaking excessively when warmed up.
 
Top