Did I ruin my engine?

kelownafred

New Member
Local time
3:25 PM
Joined
Jun 9, 2022
Messages
5
I have an 80cc 2 stroke on my mountain bike. Coming home from work the bolts hoding the muffler fell off. The muffler stayed attached to bike with clamp I had installed so made it home in a noisy way but got here. Next day I cut a new gasket and re-installed muffler with better bolts and some Lock-Tite. But the bike wouldn't start. Tried it many times up and down my road but... nothing. Reading on here someone posted that a possible reason for no start is a plugged exhaust. Took muffler back off and was shocked and embarrased to see that the new gasket I had cut only had holes for the bolts but I'd forgotten to cut the hole for the gases to escape. Felt foolish but glad to have found the problem. Cut gasket properly that night and expected to start her up the next day. But.... nothing. I have spark... I have fuel... the compression is good (145psi) bu no go. Did I damage the engine somehow by trying to run it with a blocked exhaust?? Any help would be appreciated. Thanks
 

Risk Man

Well-Known Member
Local time
6:25 PM
Joined
Oct 28, 2021
Messages
443
what about taking the muffler off, the plug out and the intake and let the cylinder "dry out". Perhaps it got "flooded" with no where for the unspent fuel and oil to go.
 

noah9988

Well-Known Member
Local time
6:25 PM
Joined
Jul 3, 2021
Messages
414
I can't think of any reason you could have ruined the engine. I think @Risk Man is right and the bottom end might be flooded. If that's the case you can try to start it by holding the throttle wide open and with the choke off to try to clear it.
 

kelownafred

New Member
Local time
3:25 PM
Joined
Jun 9, 2022
Messages
5
I can't think of any reason you could have ruined the engine. I think @Risk Man is right and the bottom end might be flooded. If that's the case you can try to start it by holding the throttle wide open and with the choke off to try to clear it.
I took off carb and muffler, turned bike upside down and there was a bit of gas that came out...let it sit over night and .... nothing. Doesn't even try
 

weefek

Well-Known Member
Local time
6:25 PM
Joined
May 14, 2022
Messages
498
How long are you taking to start the engine? Pedaling the engine down the road for how long? choke on choke off?
 

kelownafred

New Member
Local time
3:25 PM
Joined
Jun 9, 2022
Messages
5
To the end of my street it's about 250 yds slightly down hill... tried choke both ways, throtle opened and closed... put a little gas on top of the piston as a last try....nothing
 

weefek

Well-Known Member
Local time
6:25 PM
Joined
May 14, 2022
Messages
498
This seems to me like something simple is being missed. What spark plug are you running? Are you 100% sure you have spark? Riding it for that long without running could cause wear issues if fuel/oil isn't being run through the engine...
 

kelownafred

New Member
Local time
3:25 PM
Joined
Jun 9, 2022
Messages
5
I bought new plugs that were recomended online Champion CJ7Y... there is definite spark... another reason I put a little fuel in the cylinder is to lubricate the rings
 
Top