Engine wont start (yes I've searched)

Discussion in '2-Stroke Engines' started by Jeff T, Sep 12, 2010.

  1. Jeff T

    Jeff T New Member

    So about a month ago I was riding my bike to work when i noticed the spark plug was loose, i tightened it down and kept riding. About a block later i heard a loud pop (sounded like an electrical pop, as if something just fried out), the bike stopped running and wouldn't restart. After doing some research around the forums i did all the usual tests. Removed my kill switch, no luck. Checked the spark, no spark, got a new plug. Still didn't start, got a new magnito coil. Still doesn't start.

    It must be something non electrical but i cant understand what because my bike has been running perfect aside from the loose spark plug which had been retightened a few times.

    Anyone have a similar problem? What am i missing here?

    Thanks in advance!

  2. Al.Fisherman

    Al.Fisherman Active Member

    Did you run across this?????

    Did you remove the magnet and check the woodruff key? There are a total of 4 on these engines, one of which is under the magnet and if sheared, the bike will NEVER start and run.

    Last edited: Sep 12, 2010
  3. Jeff T

    Jeff T New Member

    I have taken a look at the magnet loop and the engine shaft, both appear to be fine. All wired connections are intact, I dont know what the woodruff key is/looks like however. Any chance you could post a picture or description of what it looks like and its function?

  4. Al.Fisherman

    Al.Fisherman Active Member

    Crankshaft placement is with the piston at TDC.

    Here you can see the cutaway for the key. Only seen after removal of the magneto.

    Here is the key installed. When installing key and magnet, super glue key in place, this makes for a much easier instillation of the magnet.

    This is the proper position of the magnet with key intact and piston at TDC.

    This is the incorrect magnet placement, with key installed and piston at TDC

    Function....... The key keeps the magnet in place on the shaft, this key can shear off. The engine is totally dependent for voltage produced by the magnet rotating in the coil. If the magnet rotates on the shaft the coil won't put out voltage at the proper time for the plug to fire. The key is made from a softer material then either the magnet core or crankshaft. When the key shears off, like in the case of a backfire, the key will be the first to go, thus saving $$$$$$$$$
    Last edited: Sep 20, 2010
  5. give me vtec

    give me vtec Active Member

    It's the magneto. Same exact thing happened to me and a new magneto fixed the problem. Use a strip of old rubber tubing to put between the magnet and magneto to make it easier to line up with the holes.

    For the record my magneto did not show any signs of wear after it blew
  6. Al.Fisherman

    Al.Fisherman Active Member

    Just for clarification for others...it's the coil that can and does go bad, not the magnet, magneto being both the coil and magnet. In very few cases there are signs that might lead you to believe the coil is in fact bad.
    Last edited: Sep 20, 2010
  7. HeadSmess

    HeadSmess Well-Known Member

    definitely no spark?

    if the key is the problem, then there would be spark...just not at the right times. the key locates the magnets in relation to TDC. assuming the nuts tight n the shaft is still a good fit... it will turn, just theres nothing to keep it lined up...

    but a complete absence of spark would be more electrical.

    first...wiring? blue to blue, black to black to earth, and white capped n isolated?

    what did you replace? the black box coil or the engine coil and stator?

    did you reconnect the black wire? to the engine itself?

    replacing everything usually does the trick :)
  8. Jeff T

    Jeff T New Member

    Thanks for those pics Al.Fisherman I'll make sure to double check that the key hasn't sheared off when i get home.

    As far as I can tell, there is no spark. It seems that if the key sheared off and the shaft spun freely without turning the magnet then that would be a cause for no spark. As would the coil dying. Right now i have the blue to blue and black to black (i believe the black is grounded inside the engine casing but i could be wrong) and white is capped off.

    I'm in talks with BikeBerry to get a new magneto since my engine is still under warranty.

    Just for clarification I replaced the CDI (black box that connects to spark plug and engine wire leads). I also replaced the spark plug. So all new wiring up to the engine, and as far as i can tell no spark. Anyone know the resistance readings if i were to try to test the spark plug in series with the rest of my wiring?
  9. HeadSmess

    HeadSmess Well-Known Member

    there is a resistance measurement somewhere... im not searching for it :p

    basically you should get 340 ohms (i think?) across blue/black-earth... anything majorly less is a short and anything huge is open circuit... and intermittent is also a bin model...

    whilst a measurement across the white/black-earth is only about 4 ohms...
  10. Stan4d

    Stan4d New Member

  11. Jeff T

    Jeff T New Member

    Thanks for those links, I've actually read through most of them prior to posting but I'm going to save them for any future problems i have. I'm almost positive that the problem is the magnet coil. I checked the resistance from black to blue and white to black and got no reading. Seems like the coil is shorted so im returning it for a new one. I'll let you know what happens once i get the new one installed.

    Thanks for the help!
  12. Al.Fisherman

    Al.Fisherman Active Member

  13. Jeff T

    Jeff T New Member

    I received the new coil a few weeks ago and just got a chance to install in a few days ago as i have been traveling. I am happy to say that it has fixed the "no spark" problem but the engine still will not start. I thought it may have been stale fuel so i drained out all the fuel in the tank. Then i took apart the carburetor to make sure there was no blockage or grime. Everything looked good, I emptied out the fuel that was left in the carb fuel bowl. I then replaced the carb, added a new fuel mix to the tank and tried again with no luck. Fuel is successfully getting from the tank into the carb because if i hold the prime button too long i can see fuel come out the air intake.

    I live on a large hill so i have been riding it down the hill in order to attempt a start (can get up to 30mph), no luck however. I can hear the piston moving up and down and when i give it gas it just has a low bogging noise but no acceleration. Once i pull the clutch out the engine stops. I have looked inside the cylinder and not seen any flooding, nor do i believe it is the head gasket because there is good compression when i try to crank the motor by hand.

    It seems that it might be a problem with the carb or an internal problem in the cylinder. Since im getting a spark and fuel in the carb its hard to say what is wrong.

    Any ideas?
  14. Al.Fisherman

    Al.Fisherman Active Member

    I can't (63) but my son (34) can and I'm sure at 21 you can also. Have help, remove the air cleaner, spray a SMALL amount of starting fluid in the carburetor while holding up the rear wheel spinning it with the clutch engaged. My son starts our bikes quite often showing people how easy it is to start. Remember that starting fluid has no lubricant and will wash the cylinder clean. If it starts you have a carb problem, if not a electrical (also timing) or compression problem. You might want to remove the exhaust system eliminating any possibility that it's a factor. I have a problem pull starting a small 800w (2 cycle) generator at times (if it sits awhile). I drilled a very small hole, large enough that the tip extension (like a straw) of a starting fluid can can get into. The foam filter is installed, I give it a short shot and starts no more then 2 pulls. I also have my 5500W (4 cycle) 5th wheel electric start generator set up the same way in case the battery craps out, with the same results.

    Also check or recheck the clutch to the fact that when released it is in full engagement.
    Last edited: Oct 27, 2010
  15. Jeff T

    Jeff T New Member

    So i tried the starting fluid but still no go. I removed the engine head to have a look around and everything looks good as far as compression goes, i can hear the air intake puffing out air as i turned the engine over so i know there is compression. There is fuel in the carb, but the weird thing is that when i spray starting fluid directly into the spark plug hole then try to start it I still get nothing. I first tried spraying it into the air intake as well but no luck there either.

    It seems like the spark plug isnt firing once its under compression but its a brand new plug and the spark looks strong when outside the head. I also have another spark plug that I tested and the same thing happens. I went back through my wiring to make sure there were no areas that might short when the plug is under compression but everything looks good.

    Do you think the timing could be causing the problem? It would seem like I would hear the engine start regardless of timing when i spray starter fluid into the cylinder.
  16. Jeff T

    Jeff T New Member


    Ok everyone I finally got the bike running a few days ago. Turned out that when i replaced the magneto coil (the initial problem) I installed it upside down. The white wire was on the top and the blue was on the bottom. This resulted in a miss timed spark, 180 degrees off. Once i flipped around the magneto it started up.

    Just in case anyone else is having a similar problem make sure to check that the magneto is installed correctly, blue wire on top and white on bottom.
  17. HeadSmess

    HeadSmess Well-Known Member

    :lol: ya goose :p

    good you admitted it so as to help anyone else out though :)