Robin Eho35 Rough Idling

Discussion in '4-Stroke Engines' started by Mike St, Mar 22, 2012.

  1. Mike St

    Mike St Member

    I'm having some problems with my new Robin EHO35. It idles a little rough and I don't know what the probllem is. I'm running on 10% ethanol, the only gas available in Illinois. The carb body is very sensitive to the touch, so I tightened down on the screws but still some rough idling. This is a new engine and should run perfectly. I also have a Tanaka purefire 32cc which runs smoothly and idles perfectly. It also seems to make less noise than the Robin. Maybe it needs to breakin more. Any ideas what wrong?
     

    <
  2. BigBlue

    BigBlue Active Member

    Mike St,

    I don't know if this will solve your problem, but another member had a problem of his new engine not starting due to an O-ring sucked into engine from the carb. It's a possibility, but I'd look for other solutions.

    http://www.motoredbikes.com/showthread.php?t=36795

    Good Luck,

    Chris
    AKA: BigBlue
     
  3. I had the same problem If you make it idle lower or higher it will smooth out
     
  4. Mike St

    Mike St Member

    It seems to work better now. I put in newer gas and adjusted the idle like you said. The combo of this engine plus a friction drive with a 1 inch diameter roller is perfect, enough low end torque and good top speed for the city. Everyone should own a 32cc friction drive bike.
     
  5. LR Jerry

    LR Jerry Well-Known Member

    Glad the problem is fixed. My first thought was it might be your plug and/or gap. My Robin has ran great for over a year now. However to my good fortune there's a station here which sells 100% gas. I've got a crank kit on my auto shifting bike.
     
  6. HeadSmess

    HeadSmess Well-Known Member

    until it rains :(
     
Loading...