Batavus hs50

heyhi

Active Member
Local time
6:38 AM
Joined
Sep 28, 2022
Messages
109
I know these are slow. M48 25 mph engine. Sha1515 carb, 15 intake, performance reed block from treats.

Besides the usual response as using it as a doorstop, what can I do to get some more bottom end on this. Has anyone successfully bolted parts onto here with results? I'm not familiar with porting and port timing or any of that stuff. As of right now my skills are limited to bolt ons but I did open the exhaust port on the head .

I have the treats high compression super street head. When I installed it, the Piston was hitting the spark plug, it was also pretty much impossible to kick the clutch over, I had a previous air leak due to head studs stripped and not being able to torque them.
I replaced studs fixed the base gasket air leak but I'm not sure if I should bother installing this head since it's hitting the plug. I'm pretty much all over the place trying to get some better low and torque so I can accelerate better and go up hills better.
 

Chainlube

Well-Known Member
Local time
3:38 AM
Joined
Jan 5, 2020
Messages
7,429
I know these are slow. M48 25 mph engine. Sha1515 carb, 15 intake, performance reed block from treats.

Besides the usual response as using it as a doorstop, what can I do to get some more bottom end on this. Has anyone successfully bolted parts onto here with results? I'm not familiar with porting and port timing or any of that stuff. As of right now my skills are limited to bolt ons but I did open the exhaust port on the head .

I have the treats high compression super street head. When I installed it, the Piston was hitting the spark plug, it was also pretty much impossible to kick the clutch over, I had a previous air leak due to head studs stripped and not being able to torque them.
I replaced studs fixed the base gasket air leak but I'm not sure if I should bother installing this head since it's hitting the plug. I'm pretty much all over the place trying to get some better low and torque so I can accelerate better and go up hills better.
There's a couple simple things you can do, can you post a couple pictures of your setup?
 

heyhi

Active Member
Local time
6:38 AM
Joined
Sep 28, 2022
Messages
109
There's a couple simple things you can do, can you post a couple pictures of your setup?
Here's a couple of pictures it's pretty stock. It has a 22 mm exhaust which is stock. Front sprocket 13 tooth rear 50 also stock.
Sha15 mm carburetor that I added and I think it's a 62 Jet right now
" Not sure if I'm running rich or not"
"Not sure if my idle is optimal "
15 mm intake I also added
And performance reed I added.
That head in the picture Isn't on the bike.
You could tell by the picture that it's basically a flat piece with no lip it only has the hole for the piston. "See above post"

Here's the reed
Note.. order for me to get this to fit I had to pretty much cut off the whole reed holder. To where it's only the two screws and a piece going across.

Carburetor

Intake

Spark plug
NGK BP6HS Standard Spark Plug https://a.co/d/cvWCOpr
 

heyhi

Active Member
Local time
6:38 AM
Joined
Sep 28, 2022
Messages
109
Right now stock cylinder/head
 

Attachments

  • 20220929_020521.jpg
    20220929_020521.jpg
    117.7 KB · Views: 47
  • 20220929_020504.jpg
    20220929_020504.jpg
    109.1 KB · Views: 44
  • 20220929_020419.jpg
    20220929_020419.jpg
    122.1 KB · Views: 51

Chainlube

Well-Known Member
Local time
3:38 AM
Joined
Jan 5, 2020
Messages
7,429
Did the plug make a mark on the piston? Put the stock head on, get a piece of solder wire and bend it a bit and slip it in through the spark plug hole, turn the engine over so it compresses the solder. Measure the thickness of the solder, then repeat with the new head. The new head looks like it is recessed too much.

Mopedarmy says it's a slug of a bike on take off but should do 35mph. The most common reason for poor performance is a bad belt. Here is the replacement part #s you can get at any auto parts store.
Gates 9319, Dayco 17320, Goodyear 17321, metric # 13A0815.
 

heyhi

Active Member
Local time
6:38 AM
Joined
Sep 28, 2022
Messages
109
Did the plug make a mark on the piston? Put the stock head on, get a piece of solder wire and bend it a bit and slip it in through the spark plug hole, turn the engine over so it compresses the solder. Measure the thickness of the solder, then repeat with the new head. The new head looks like it is recessed too much.

Mopedarmy says it's a slug of a bike on take off but should do 35mph. The most common reason for poor performance is a bad belt. Here is the replacement part #s you can get at any auto parts store.
Gates 9319, Dayco 17320, Goodyear 17321, metric # 13A0815.

Thanks , no damage was done with the piston. I never started it I just cranked it a bit. Will change the belt soon. Oh yeah it is a slug to take off. I mean this thing is a 🐢. I'm ordering new rings. Il do the solder test on the stock head once I get those in so when I take everything apart I'll throw the performance head back on I'll report back once I do this I appreciate your help
 

DAMIEN1307

Moderator
Staff member
Local time
4:38 AM
Joined
Jul 23, 2020
Messages
7,289
Location
Alamogordo, NM, USA
Mopedarmy says it's a slug of a bike on take off but should do 35mph.
Oh yeah it is a slug to take off
I found this article as well on that bike.


the HS50 has single-speed transmission with automatic clutch and can reach a top speed of 35mph. Due to the nature of the centrifugal clutch, initial acceleration is very poor and renders the machine very unstable for the first few yards.
 

heyhi

Active Member
Local time
6:38 AM
Joined
Sep 28, 2022
Messages
109
Thanks all .
Since I have the bike running and it seems pretty good before I do performance I want to fix this other problem I have. Hope I can get some help here. I'm not sure if I should start new thread.

When I walk the bike especially I hear a noise that's coming from the belt pulley area. It doesn't seem like it's coming from the clutch .if you pay attention to the holes on the pulley, it happens when either hole hits the top or the bottom. Like every half a turn basically but I'm not visually seeing it hit anything. Here are 2 videos .


Vid 2
https://photos.app.goo.gl/kpdR4dAL3GLfyau98

Pulley.

If I can get this pulley to work
. I can kill two birds with one stone. What I mean is this pulley is from the 20 mph version. It has an 11 tooth sprocket on it verse my 13th tooth sprocket from the 25 mph version. Dropping to an 11 tooth sprocket should give me more low end torque. I attached a picture showing the difference between the two versions
 

Attachments

  • Screenshot_20220930-124111_Chrome.jpg
    Screenshot_20220930-124111_Chrome.jpg
    84.3 KB · Views: 39
Top